Emails in outbox before upgrade cannot be sent after upgrade


I had a ~2 months old K9 version with a certain number of emails in my outbox. Since my phone was not connected to the internet they could not leave it.
Today I upgraded to newest K9.
Now my emails from the outbox are not sent when I hit ‘send emails now’.
I can see a notification that K9 is attempting something, but it disappears almost instantly.
Even if everything was working fine before the upgrade, I’ve retyped the password. It still does not work.
I assume there’s an error but I don’t have time to read it. Also I did not find any mean to see the any logs in K9…

What can I do to get my K9 outbox working again?

1 Like

I have found that the new K9 will not attempt to re-send failed Outbox messages. I do not think that your issue is related to the upgrade. The new K9 does the same thing to me when I try to send while out of cell coverage (such as hiking in a National Park) unrelated to the upgrade.

The only way of sending that I have found is to choose “send as a new message” in the message options. This will bring up an edit window with your old text pre-populated. You can send this new message just fine.

The old message will remain in your Outbox until you manually delete it.

This is a kluge workaround, but it at least prevents you from needing to retype your original message(s).

1 Like

Interesting, I hope that gets fixed, having so many messages stuck in the outbox and having to send them all again one by one sounds exhausting!

1 Like

What is your mail service provider that you are trying to deliver the messages to? Knowing that might give some ideas of where the issue is. [I haven’t run into an issue getting messages, that have failed on initial delivery to my MSP, to send using the “send messages” option.]

It’s Gmail (, configured as recommended on Gmail’s docs : TLS/ssl,465, normal password, etc).

I tried from both 4G and wifi…

1 Like

Sending emails with data activated worked after the upgrade.
I’ve just tried to send an email while data off, the. Activate data then hit ‘send messages now’. It works.
So apparently only emails that where in the outbox before upgrade seem stuck in outbox…

1 Like

When you try the “send messages” (there’s no “now” that I see) selection on the outbox with the “stuck” messages do you get an error notification? I would think you should - I get one associated with the triangle error icon. If so, what does it say – including any IPnumbers that it might show.

From initial message:
“I can see a notification that K9 is attempting something, but it disappears almost instantly.”
“Also I did not find any mean to see the any logs in K9…”

If you have any solution for those problems, I could help you more…

I might have done a “empty cache” to free some of my SD card space.

Is it possible that emptying the cache of K9 would have removed the /content/ of the Outbox messages, but left them in the list in the Outbox, so that the problem would be that when K9 cannot access the content anymore when it tries to send these messages.

New messages are sent without any problem… Even sent stored in Outbox for a moment, then sent later