Earthlink IMAP not working

Same settings work fine with the Samsung app. When clicking NEXT to verify, the server response is almost immediate. It doesn’t appear to be an error, but possibly some confirmation.

K-9 VER. 6.802

SAMSUNG S23, Android 14

It looks like the account was initially set up as a POP3 account in K-9 Mail and you’re now trying to point it to an IMAP server. That won’t work.

Delete the account in K-9 Mail and set up a new IMAP account. Then using the settings as visible in your screenshots should work.

That was it! Thank you! Did an import from another device.

IMAP appears to be mirroring and displaying the folders based on the CLASS settings, yet syncing is not working correctly. Whatever I do in Webmail reflects in K-9, yet not the other way.

Any deletions in K-9 does not reflect in Webmail even after much elapsed time. The classes are correct. Syncing does not work in 1st or 2nd class folders. PUSH option is selected for the folders first and/or second class. Tried PUSH on all classes as well.

Verified that SMPT side (Port 587/StartTLS) is working. Even tried without security enabled.

Always suspect of any glitches with Android 14 so tried on another device running Android 8.1. Same issue.

Messages not being deleted from the server when “When I delete a message” is set to “Delete from server” is a bug. Can you please record a debug log while trying to delete a message? See LoggingErrors · thunderbird/thunderbird-android Wiki · GitHub

Okay, exported logs after a simulation.

Github issue #7818

Thank you for the follow-up!