K-9 gives duplicate/multiple Notifications and shows some messages 2-3 times on the unified new messages screen.
I’m using K-9 6.701 (latest beta), and I have two e-mail accounts: one from Gmail and one from Fastmail with my own domain.
CKetti told me in a chat (matrix) on 18.4.2023:
“Open a message, then tap the gray area to open the message details. Scroll all the way down to see which folder a message resides in. Then exclude the folders that contain copies of messages (i’m guessing you’re using gmail and have included the “all mail” folder in the unified inbox… don’t do that)”.
So, I checked a few messages, and indeed some were in “All Mail”.
I hadn’t made any changes in K-9 to the default settings regarding All Mail and notifications.
I then went into the K-9 settings for my gmail account and… cannot figure out what many of the settings mean. It might be under “Notifications / Notification folders”, but there it starts offering choices called “Only 1st class folders”, “1st and 2nd class folders”, “All except 2nd class folders”, and “None”. I have no idea what these “Classes” are, or whether selecting something here would fix the multiple notifications and copies displayed.
OK, I’ve changed the “Manage Folders” / All Mail / Poll+Push+Notification" to “2nd Class”, and I also changed the “Notifications folders” for the Gmail account to “All except 2nd Class”. Is that what it should be?
It’s more common to set the Folder poll class and/or Folder push class of folders you want to sync to 1st Class, then set Settings → [Account] → Fetching Mail → Poll folders and/or Push folders to Only 1st Class folders.
Additionally, you could change Settings → [Account] → Notifications → Notification folders to Only 1st Class folders. But folders that aren’t synced automatically shouldn’t generate notifications.
So far, using my changes above, I have not had duplicate notifications or messages. If something turns out wrong, I’ll try your “more common” settings. It’s just that the terminology is so abstract for my mind, and I’m already at the limit here in what I can comprehend, I don’t want to “play” with those settings anymore.
Here’s an idea I posted in another thread:
Instead of calling them “Class”, perhaps a more intuitive naming method might be beneficial. Perhaps something like this:
1st Class --> Prefer ON or Active
2nd Class --> Prefer OFF or Inactive
None --> Default or Neutral
It would be a huge improvement, even if the code logic might have to be adjusted (slightly?).
Or something similar, that is also more intuitively comprehensible.