Clear OAth 2.0 Password/Certificate

My email provider recently switched to using Office365 on the backend. I had no say in this, so it’s a bit frustrating. I finally found the imap setting for my accounts, and set about configuring K-9 to use them, since it’s kind of the point to have email on a cell phone that actually downloads email. :slight_smile:

I have multiple email addresses and accounts. So I’ve gone through and configured them one by one. At first I tried normal, and encrypted password both of which failed. I then, given my knowledge in the profession, figured maybe OAuth 2.0 (a known security measure in webservices from Microsoft’s TFS) might be the ticket.
Upon selecting OAuth as the method, it went to a “login screen” via an internal web browser. I was able to log into 3 of my 4 accounts. The 4th account however, is giving me backlash of an invalid password.
I have tried deleting that account, restarting the app, restarting the phone, and every time I try to re-add that account, I do not get a “ENTER PASSWORD” on the OAuth login screen. It is like K-9 has saved (even when I told it not to) whatever mistyped password was put in the first time, and i can’t tell it to “hey, let me reenter that information!” What if I want to change the password for my email, I’m eternally locked into the first password I’ve entered.

For an account in K-9, how to I tell it to PURGE an OAuth Certificate, or password information to inspire it to allow me to reenter that information.

Jaeden “Sifo Dyas” al’Raec Ruiner

K-9 Mail does not hold on to any information when you remove an account. However, your browser is used for the OAuth flow (it might look like it’s an in-app browser because Chrome custom tabs are used, but it’s your default browser). The browser might hold on to some information. Try clearing the cache and/or cookies for your email provider’s domain.

1 Like

That did help, because at least it asks me to log in again, but I still get the same error.

Username or password incorrect. (Command: AUTHENTICATE XOAUTH2; response: #3# [NO, ATHENTICATE failed.])

But i have verified a dozen time, logged in via my PC/Web mail ever time with the EXACT same credentials.

I even tried removing one of my accounts in K9, as i have two email accounts configured as such:
where the only difference between the accounts is the domain name. That shouldn’t make a difference, but I wasn’t taking chances.
Why is this one account not working when all of my other accounts work perfectly?