Changing a password breaks K-9

I use K-9 on two accounts from a mail server in a domain I own hosted by FatCow.

I changed the password on one of those accounts. K-9 can’t connect and returns either

  1. K-9 is unable to parse TLS packet header if I use the same ports used for the other account,
  2. authentication failed, or
    3)Username or password incorrect. (Command:sensitive; response: #2# [NO,[AUTHETICATIONFAILED], Authentication failed.])

The username worked before the password change and wasn’t altered in this process. The password is correct, it works on my desktop client and using Roundcube Webmail.

The account I didn’t change connects as it should, using ports 993 and 465, but I didn’t change that password.

The last time I changed a password, I had to try three or four ports before K-9 connected, and I ended up using port 143.

What are you trying to accomplish?
send and receive email after password change

What have you tried so far?
Verified password, verified ports, compared to a second account on the same server, tried the same ports as used on the second account.

What K-9 Mail version are you using? 6.400

What Android version and device are you using?
Samsung S-21+ Android version 13.

I have the log but it’s large, I can copy and paste it here if it will help.

Old Chief

Did you check the setup description by your mail hoster?

Generic Email Client Settings

These are the generic settings and should work for any email client or mobile device.

Setting What You Input
Username: Your full email address
Password: Your email password
Connection Type: Server & Port info
POP Incoming Server:
Incoming Port: 110 (or 995 with SSL enabled)
IMAP Incoming Server:
Incoming Port: 143 (or 993 with SSL enabled))
SSL (Optional): Enabled or Disabled
Outgoing Server Authentication: Enabled
Outgoing Server:
Outgoing Port: 587 (or 465 with SSL enabled)

Thanks for replying, I appreciate you taking the time, Yes, I tried every variation, then I nuked and recreated both accounts, and on the second try, it worked. I have no idea why, but after 40 years screwing around with computers, I know when I’m beat. :crazy_face:


greetings. my father inlaw change his phone and we could not log in back to his account

Same mail provider? Please give more information: what K9 version, mail providet, if you can login to tge mail portal of your mail provider, etc

I got hit by this problem. After I changed the password once, sending email broke with failed authentication. I then reset the password a second time and now received and sending are both broken (failed authentication). I’m using version 6.400. I’m using OnePlus 6 phone/Android 11.

I have other email accounts on the same phone to the same server and they work fine. I tried deleting and recreating the account in K-9 but hit the same problem. Log is here: k9 email log -