Cannot see mail details in notifications anymore

Since the latest major update I cannot see sender and subject in the notifications anymore. I only see the mail account name and the number of new mails. First I thought I see this only when I have more than one mail and K-9 Mail just groups them. But it’s also when there is only one new mail. I checked all settings within K-9 Mail and in the notification settings of that app in the operating system, everything seems OK. I use Andoid 9 on a Samsung Galaxy S8+.

Is this a new “feature” or is there a setting I did not find yet?

Hmm, I do see the message preview. So it’s not a “feature”

OK, thanks.

Any ideas on how to find the corresponding setting?

Try setting Settings > General settings > Notifications > Lock Screen Notifications to Same as when screen unlocked. It’s quite possible the lock screen “detection” is not working properly on your device and only notifications with reduced information are created.

Fixing problems with notifications is the next big item on the roadmap.

Thanks. I tested this and unfortunately it did not make any difference. I still cannot see any mail details.

A change to that setting only affects notifications created after the setting has been changed. Existing notifications won’t be updated.

That’s what I already thought. And I got a new notification for a new mail. But it looks the same.


I guess you’ll have to wait until we get to fixing notifications. I don’t think the current version contains enough logging so that we’ll be able to find out what’s not working for you.

If you create a ticket on GitHub for the bug, we can let you know when there’s a version available that might fix the bug or one which contains enough logging so we can find out what we need to fix.

Logcat of no use here?

We added detailed logging for the decision whether or not to create a notification. But there’s no logging for what data goes into a notification.

But going through the code I noticed there’s an additional notification setting under Settings > General settings > Hide subject in notifications. You probably want to set this to Never.


Thanks, that’s it! It was set to “When screen is locked”.

1 Like