Cannot get Push notifications to work on my Inbox folder

Using Sony Xperia 10 IV running Android 14
Installed K9 Mail version 6.803

I have one email account (so far) on K9 Mail with the Inbox classified as First Class for Push. All other folders classified as None.
At the same time I have all other folders set 2nd Class for Poll and None for Push
I have (or am trying to have) Push set for 1st Class folders only and have Poll set for 1st & 2nd Class folders every 15 mins.
Each time I set Push for !st class it momentarily connects and I have any waiting emails arrive. I am able to occasionaly get this setting to stick for a few minutes but it then reverts to None. While it is working I am getting the “@ waiting for emails to arrive” notification ( as I am deliberately keeping the notification visisble at this stage)
I have the Alarms and Reminders permisson enabled - although this can sometimes disappear fron the settings of the App and also in the permissions list. Reinstalling K9 Mail usually resets this.
I have Battery set for “Unrestricted” in the Android Battery settings.
I think I’ve covered all the reasons why I might have the problem but could be missing something glaringly obvious? I could live with 15 min polling but would like push working on at least my main Inbox.

I would love to get this to work as I have had Firefox and Thunderbird installed on my PC for years and was looking forward to using Thunderbird on Android.

I “think” I might have fixed it … Currently have had Push 1st Class folders set for a fairly long time (30mins)
I switched the Local Folder size to “All messages” - I had had it restricted meaning the app was reluctant to download more?? Hope this helps others if it is the solution? :smile:

No luck… That turned out to be a temporary fix while the app kept connection to the server while it downloaded emails to a local folder. So I’m still no further on.
My permission for Alarms and Reminders has now disappeared again in the settings but still appears to be on??

Was this a fresh install or did you just recently get the Android 14 update while K-9 was already installed? (The 10 IV was released in 2022, so I guess it was an update…)

There is a known bug with the new permissions model in Android 14. Apps are supposed to re-request the new permissions after the update, but K-9 does not do so.

The fix is, to make a settings backup in K-9, then uninstall K-9, reinstall it, grant all permissions on first start, and finally restore the settings.

Thanks for the reply… It was a fresh install to begin with.
I have tried backing up the settings and reinstalling the app before but I might have another go at some point to see if your advice works if I do everything in the order you’ve suggested.

Push will get disabled automatically if a server doesn’t announce support for the IMAP IDLE extension. Maybe your provider is using multiple servers in the backend and not all of them support IDLE? That could explain things working fine at first and then the Push setting being disabled on its own.

To get a better idea of what’s going on, you could record a debug log. See LoggingErrors · thunderbird/thunderbird-android Wiki · GitHub

I think you maybe right… And there appears to be some history here. Found this on a quick search. I am also having difficulty with an address ( ISP is UK based)

Oddly enough my activation email for this forum using this email address never arrives despite repeated requests. I’ve used by backup Gmail address to enrol.

Seems BTInternet and K-9 don’t get along nicely in more ways than one :slightly_smiling_face:

I updated my K9 on my Nokia 5.3 (Android 12) a couple days ago to v6.804 and thought it was going well until I opened Thunderbird on my desktop this evening to see 6 new emails sent over the past 12 hours without notifying me on my phone. I checked my phone, forced a refresh in K9 to no avail, so I rebooted the phone. Even then the emails didn’t come through after 5 minutes so I opened and forced another refresh and they finally came through.

Is there a bug with the new version? Is there a way to rollback via Google Play to the previous release?