Address Copied to Clipboard Not Wanted

Samsung Chromebook 3 / ChromeOS Version 99.0.4844.57 (Official Build) (64-bit)
K-9 Mail v. 5.807
One POP3 account

Sometimes when I am viewing an email in the Inbox in K-9, the sending address of the email will get copied to the OS clipboard. This seems to happen randomly and unpredictably. It is a definitely unwanted behavior. Why does this happen, and is there any way to prevent it? TIA.

Mail addresses (both sender or receiver) and mail subject can be copied by long pressing on it. Then a notification shows on bottom which says “Subject text / Address copied to clipboard”.

Are you sure that you did not trigger copy action accidentally by your own?
How did you see that the addresses are copied? Did you see the notification? Or just the text in clipboard?

I am using a Chromebook which does not have a touchscreen, so there apparently does not seem to be anything such as a “long press.” The cursor is controlled with a touchpad and the keyboard. At seemingly random times when reading the Inbox, I get a little message pop up in the middle of the email text that the address has been copied to the (OS) clipboard. If I paste from the clipboard, the contents are the address copied from the email in K-9, not what I had put there previously on my own. I cannot guarantee that it is nothing I am doing, but I don’t seem to see a pattern. It is irritating, because sometimes I want what I put in the clipboard to persist.

On my Chrome OS device a long click using the touch pad seems to trigger the same actions as long-pressing on the touch screen.

That may be it. This Chromebook came with no instructions – just figure it out by yourself – and the online “Help” didn’t seem to be much help. I run my fingers so lightly over the touchpad that I didn’t even know that it might be possible to press harder on it at the lower edge to simulate anything like a “long press.” I will try it out when some new email comes in to K-9.

With some experimentation on new email following @cketti 's statement, it appears that a “long press” in K-9 is possible on the Chromebook touchpad. I never had any idea that was even possible. Apparently I was doing it without even realizing it when the pointer was still over an address in the header. So we can close this thread for now as problem solved.

1 Like

Good news!

Best you would mark one of the messages as “Solution” for this thread.

How do I do that? I don’t know how to mark something as “Solution” other than what I said in a comment in the thread.

I see you found it :+1: