5.8: regression: unread-message notifications persist even after message is read on another client

Given the following chronology:

  1. incoming email arrives
  2. k9mail receives push notification from dovecot, notifies me on my phone
  3. I read and delete the new email, using my desktop client (without touching phone)

Under old k9mail, the new-mail notification would quietly go away. Under new k9mail, the notification persists even though the message is no longer new or even in existence.

These notifications pile up: multiple such cycles keep adding to my notifications on the phone screen.

v5.803 fixes the problem


It’s still happening on a Fastmail IMAP account - and I’m running v5.803. But Gmail and Yahoo Mail IMAP both seem to work. All of my POP3 accounts work too.

v5.804 can be a solution for you.
It can take a while until it is in the play store.

Fixed a bug where Push didn’t work with some servers
Don’t connect to the incoming or outgoing server when passwords haven’t been provided after import
Added missing scrollbars in screens showing the folder list
Tapping the app icon should now always bring the app to the foreground instead of adding another message list screen
Updated translations

I take it you are the developer?

Hello! :slight_smile:

I don’t know if this should be a new thread or not, since it’s the same thing, but in reverse.

I’m talking about the badges, meaning the little notificafion that appears on the corner of the app icon that tells you how many new emails there are.

I have v5.803 (Android 7.0) as well, but my problem is that I don’t get any at all, ever. And yes, I do receive emails, so no, it’s not because nobody loves me.

I do use (latest) Nova Launcher Prime (prime=paid), but I did specifically enable badges for K-9 and this is the first time I have not seen badges appear with new emails waiting on any email app (or any communication app). It’s always worked well. So while it could be Nova, I just wanted to let you know that it has worked well for me and that I did double check go make sure that I do have badges enabled for K-9.

Any ideas? Or should I in fact start a new thread with this one? I put it here right now, because I figured if you’re already working on them, you’d have the information for my issue at the same time. :slight_smile:


Sorry but I’m not the developer. It’s better you make a new thread.

OP here: confirming as fixed in v5.803. Thank you.

1 Like