4g not working for K9

K9 not getting or receiving on 4g but is ok in WiFi

That normally means that your phone is configured to optimize the battery usage by turning off the app’s “background data” access when on 4G.

Thank you Gunter. Battery optimization is set to Not Optimized so assume that cannot be the reason.

I also use the Outlook.com App for other mail accounts and this continues to function perfectly when I’m away from my home WiFi and then 4g - Internet access is ok on both, it’s just K9 that send or receive.


Battery Optimization is NOT the same as Background Data, that’s a seperate setting.

Thank you Nimuey - much appreciated!

I very puzzled because I cannot find the K9 Screen “Mobile data and WiFi” that you sent to me. Here is all my feedback:

I’m running K9 Version 5.807 which I believe is current.
I’m using an Android Motorola phone (MotoG Power 4G)
I’m also using push on all folders.
The only account in my K9 is a gmail.address - it’s not the address as I’m using for the forum.

Having taken the time to go through the all the settings menus extensively, and created my sequence of 7 images, I was very disappointed to learn that as a new forum member I am only allowed one image - and I’m only “told this” having put it all together and found the refusal right at the “send” stage.

This is what I can see:

From the K9 menu, top left hand of my Unified Inbox, I can go to settings and then to my account. Regardless of going to general settings for the app or settings for my specific account within the app, I cannot find anything like the image for “Mobile data and WiFi” that you kindly sent to me.

If I go into Network from the screen image below …my single ALLOWED image…

…I can then get into “Background sych” which is set to “when auto-sych is checked” which is indeed checked.

So I don’t know how to get anything like the Image that you sent to me Nimuey
Still very puzzled.


“Mobile data and Wifi” is not a menu in K9 itself but a setting of your Android OS. It might look differently on your phone. Best you look in your Android settings for “Apps” - K-9 - Mobile data (this is how it is named on my S7). But as I said, might look different at your phone

Thank you very much stphn - I’ve found this now!! See my image below:

The “Background data” was already switched on.
“Unrestricted data usage” was switched off (but data saver was not on anyway) - so I’ve switched this on now too, but K9 still does send/receive.
As you will see your screenshot has a couple more rows than mine.

As stated earlier Send/Receive does work OK in my separate Outlook.com app in my TEST CONFIGURATION here at home (which is simply my home WiFi turned off on the phone to force the use of 4G). Obviously it’s when I’m out and about on trains and buses that not getting my K9 mail is the problem I’m trying to solve. Colin