Passwords Not Working

I’ve been using the K9 App for several years, without having any problems. Then recently I purchased a new (Motorola Power G), and installed the latest K9 App. I haven’t been able to set up my Gmail (4) accounts, for some reason K9 is not accepting the Gmail passwords. It has accepted my (3) other “non-Gmail” accounts passwords. I am hoping someone could help me solve this problem.
Thanks in advance.

Google, including gmail, was just suffering a wide-range outage which may have been the cause of your problem.

Things seems to be back now, so if the issue continues, I assume that you are using the “app passwords” you set up for K9/gmail use, not your regular google/gmail login password.

Yes, I too was getting authentication failures for GMail Monday evening until late Tuesday morning - on K-9 as well as Thunderbird. Not a client software issue. Google Drive and Docs, and YouTube were affected. Not an App Passwords issue.

Thanks for your replies guys. Unfortunately this problem has been going on since a few weeks ago, so the Google problem the other day isn’t the problem. As for the “app passwords”, I’ve been using the regular Google/Gmail login, I didn’t know there was any other way to log in. I have just uninstalled/re-installed K9, but it is still not accepting the passwords.

K9 doesn’t support OAuth.2, yet, so is considered a “less secure” app by gmail (and some other mail providers). So, to get it to work you need to follow the gmail setup steps, including setting up/using “app passwords”, as outlined at:

1 Like

Thanks for the help, but unfortunately even after going through the process of turning “ON” the Less Secure Feature that Google has, I still can’t get my Gmail password/s to work in K9. I’m not sure what I can do next.

did you create, and use, app-specific passwords? you have to do that, in addition to turning on the “less secure app” option. see the “Use an App Password” link toward the bottom of the page referenced in my previous reply.

1 Like

Thank you very much for your reply, and I apologise for taking so long in replying.
I now understand what you were trying to explain to me, ad finally realized that an App Password is needed, and the only way to get that is by setting up a 2FA system. I have done this with one of my 3 Gmail accounts, but may I ask that to set up the other two Gmail accounts, do they need individual 2FA set ups? I am thinking that if all 3 accounts were now set up to gain access through one of the accounts, using a single 2FA set up would work for all three Gmail accounts, and possibly any other Email accounts being used. But I prefer to keep each email as an individual sign in, as opposed to one Gmail account in for every email account that I have.
I hope this hasn’t got you confused in what I am trying to explain. I certainly hope I haven’t caused a headache for anyone reading this!

i don’t believe that you need 2fa for any of this (i don’t think that google forces 2fa). you (simply) need to log into your google/gmail account via the web interface and set up app password(s) for that account once logged in. you also need to allow “less secure app access” for your account, as outlined in the google document referenced above. if you have more than one account, then log out of the first and repeat for the second and third. for google accounts, logins, app passwords and 2fa are account specific so if you have multiple gmail/google accounts you simply set things up individually for each.

Thanks again for your help. When I went to the Gmail page that let’s us create App Passwords, I would find there being nowhere (as in link or button) to tap/click, in order to move forward. After doing a little more research within the Gmail pages, I found this page that states a 2FA system is required, for having/using the App Password feature…

So I have now set up each of my Gmail accounts with the 2FA system.
Many thanks for all your help, it really has been appreciated.

Hello all,
I am using outlook mail and it worked perfectly without 2FA. However, after activating 2FA, it wasn’t logging in. I have tried app password as well, it worked on the first try for a few hours. When it struggled again, I tried the app password again, it didn’t work out.
Any suggestions?

I’m having the same problem. Setup the app password works fine in Outlook, but not in K9 mail w/pop. Given its corporate email, I don’t have access to change to ‘less secure apps’. Guess we’re looking at having to wait until OAUTH.2 is implemented?