Outlook Oauth2 - Cannot connect to server. (Command: NAMESPACE; response: #4# [BAD, User is authenticated but not connected.])

This is probably related to our issue - Redirecting

Sounds like it. I will monitor that thread.

No need to monitor that thread, it’s a year old and already closed - maybe try some of the possible solutions mentioned in it :slightly_smiling_face:

Read the date and not the year. Thank you.

1 Like

What do you mean? It’s from January 2022 and clearly says “This thread is locked. You can follow the question or vote as helpful, but you cannot reply to this thread.”

it’s possible that m$ has resolved this issue. i’m seeing reports on the mailing list for a desktop mail client, where similar issues have been reported for the ~last week, that things are (suddenly) working again without any special user action. I don’t have any office365 accounts so can’t confirm this myself.

I think the message was thanking you for pointing that out. Read the first sentence again as the first person past tense of the verb to read. The first few times I read it in a manner that elicited the same response as your reply before realizing that the other way was more likely due to the “thank you” at the end.


Thanks for pointing that out … now that you mentioned it I do realize it can be read in 2 very different ways lol. I really shouldn’t post/reply right after getting up :innocent:

Sorry for getting it wrong @cubsmt :slightly_smiling_face:


Still broken for me on both desktop client (Thunderbird) and K-9. Tested this moment.

Still broken on my phone as well.

Does K9 support monitor this forum? Would be helpful if they would chime in, even if just to let us know they’re aware of the issue.

Indeed, that would be great. Also, it would be great if they consider to implement the “ipv4 only”-option. (The network menu of K9 is quite empty :wink: ) Although the mistake is likely caused by Microsoft, this work around seems to work smoothly (with Thunderbird or Fairemail (which is ipv4 only by default if I understood it correctly)).

1 Like

I don’t have a way to get ipv4 only on my phone so how do I get around that. Am I missing a setting inside of K9?

I have the same problem, but I discovered something weird.
My ISP is for both 4G and WiFi the same (KPN in Holland).
Using my phone (4G or WiFi) or my tablet (WiFi) gave the mentioned error for result.
But when I turned my VPN on (on both devices, WiFi or 4G) and then try to connect to the O365-server it worked seamless.
I suspect that MS has updated (what’s in the name) the security policies and therefor some ISP’s have become (unwillingly) blacklisted? I do not know if that will be it, but I guess so.

Please verify that your VPN gives you IPv6 connectivity. I am expecting that you end up connecting to Office365 using IPv4 while your VPN is on. Try finding a VPN with working IPv6 and test that.

So now I got the Private DNS setup but it didn’t fix the email issue.

Have you force quit and relaunched K-9 or rebooted your phone to make sure it isn’t caching anything?

Thank you. I rebooted for a second time and now it works. Thank you for help. I wish they would just fix it.

1 Like

Now, it is working for me without changing anything (also Thunderbird without the disable-ipv6-option).
Hopefully, Microsoft fixed it although it may be too early to say (due to the unreliability of the error).