New Droid Galaxy S10E Doesn't Retrieve Email

Model Name: Galaxy S10E
Model Number: SM-G97OU
Hardware Version: Rev1.0
Android Version: 12
Android Security Patch Level
Old Phone: March 1, 2022
New Phone: April 1. 2022

K-9 Mail Version:
Old Phone: 5.600
New Phone: 6.000

I had to get a new phone. Got the exact phone and exported OLD Phone settings and then imported K-9 settings to NEW Phone. I am not able to receive email on NEW Phone, but I am able to send email.

When I go into the fetching mail incoming server settings I am getting the error message:
Setup could not finish
cannot connect to server
(Unable to open connection to POP server)

The settings were working on my OLD phone. Just not on the NEW Phone.

I am not certain how to fix this. Any help would be most appreciated. Thanks.

Which mail Provider are you using? And does IMAP work instead of POP3?

In addition to provider, what are your “…/fetching mail/incoming server” settings? What happens when you select “next” at the bottom of that screen? [i assume you did provide the password for the account when you imported the settings … as that is not exported/imported.]

I use Spectum, formally Road Runner.
I have not tried IMAP because POP3 worked until I switched phones.

Please provide all the information from the “settings/[account]/fetching mail/incoming server” settings page (except your username and password obviously) so that we can try to help you:

  • server name
  • security
  • port
  • authentication

Also indicate what happens when you select “next” at the bottom of that screen.

I have been further working on it tonight and it appears to work. I am not really keen on the lack of security on it, but it is working. thanks for your help.

Ok, great for you. :slightly_smiling_face:

But what was the solution? Would be great if you could post it here in forum so that other users who run into same / similar situation could benefit from it. And then please also mark that posting as solution.

Also, what are your security concerns:

not really keen on the lack of security on it