K9 Email Not Working

K9 stopped working for me on my Samsung S22 yesterday morning. I woke it and would no longer/send receive emails telling me my user/pw were incorrect. I’ve tried rebooting the phone, unistalling/reinstalling K9 but still the same error message. My email has been working fine on my Outlook on my desktop and also through the online email client from Media Temple. Any suggestions on what the issue is?

Can you post the exact error messages? That might help someone to help you.

In the mail settings for this account, for each of Fetching Mail and Sending Mail, step through the Incoming Server and Outgoing Server. It will do a test connection, and might give you an error there as well.

I am having the same issue. Here is the error:
The error message I get is “Setup could not finish Cannot connect to server. (Commend: NMESPACE, response: #4# [BAD, user is authenticated but not connected.})


Just to join things up, there has been a similar discussion in the forum:

My sense is that the “problem” is gradually affecting more of us.

Additionally for me K-9 no longer connects/syncs to M365 accounts when my phone (Samsung A51 updated to Android 13 on 23rd Dec - almost coincidental with the problems starting!) is connected to my Wi-Fi but OK when Wi-Fi turned off!

I’ve tried a few other Android phone Apps in the last day (FairEmail, Nine-email to name but 2) and they all work “as I would expect” and also offer a way of reauthenticating for M365 OAUTH2 in the App and granting permission by logging onto your M365/outlook account - I can’t find a way of doing that in K-9.


I have eventually found my Azure AD portal and have cross checked the permissions requested / granted for K9 and some other email Apps I have installed to test (all of which work OK BTW).

The ones that work have all, or some of, these permissions that K9 doesn’t:

I have a recollection of having to reauthorise (from within the App) one of the others a couple of days before Christmas and I’m now wondering if the owner of that App “re-registered” in Azure and if this was caused by MS “changing the rules” such that these type of Apps need extra “permissions” to carry on working?

My Azure AD shows that “I” have 3 permissions for the K-9 Email App - “offline_access”, “IMAP.AccessAsUser.All” and “SMTP.Send”.

I don’t think a “user” can add permissions to an App in their own Azure AD.



As I have thought about this some more I’m struggling to work out an association with K-9 not working over WiFi but OK when WiFi is turned off with Azure AD permission settings HOWEVER, as I am seeing 3 other email Apps working OK over WiFi I can only deduce that “something is different” with the way K-9 is set up or is processing internally.

1 Like

@mailueberfalln: Please don’t add comments to random posts. Create a new post. Describe your setup, what error message you are seeing, and what you have tried to resolve the error so far.


My one has also stopped sending comes up with Failed to send some messages Retries exceeded.

I am getting mail but unable to send/reply.

If I turn off Wi-Fi calls it works which isn’t vey helpful as I have poor reception. It was OK yesterday the only change was the install of google November update?

Sorry for typos I am dyslexic! I have rebooted twice, turned send by wi fi back on and a test mail was spent. Rebooting didn’t do anything but turning it off befor and on afterwards may have done something.