Incoming messages are showing be read

Please, why incoming messages are marked as read? This is intriguing, while I loose the overview over the new messages.
Any clue?

There’s an option under Settings - General Settings - Display, “Change color when read”, maybe try that? I use it and I can see a slight difference between read and unread mails.

Also, (assuming IMAP), are you using different clients to open your mailbox? If one client marks a message as read it will be seen as read in K9.

@njeyaakili Yes, I do… I will try to check the settings in the thunderbird…