Enhancement request "To" field in message header

I have no idea. I hated seeing “to me” and made changes almost immediately after the first time I saw it. There might be a post about it in my forum history, although I may have made the change based on information I found here without. comment.

I’m not affected by this issue. I’m just trying to be supportive of those who are.

Just out of curiosity, what changes did you make?

Bill

Just out of curiosity, what changes did you make?

Bill

It has been a long time, so I make no guarantees of accuracy.

Based on the visible differences between a single-identity account and a multiple-identity account, I think the relevant change is Account settings/Sending mail/Manage identities. Once there, pick the Initial identity and replace the Identity description with another value. This new value will appear in your messages, so try not to use the same one in multiple accounts, lest you recreate the same annoyance using a new string.

Unfortunately, that didn’t work for me. I put something into the identity description field, sent myself a message to that email address, but the email still showed “me” in the header.

I’ll keep playing around to see if I can find something.

Thanks,
Bill

I don’t know if it’s relevant, but i don’t use the unified inbox.

I turned off the unified inbox and tried again, but still get “me” in the header.

Thanks,
Bill

1 Like

From memory you need to duplicate the entry rather than change the original if it is the orig
inal default setting.

While that sounds plausible, I don’t recall doing that. I’m certain that I only renamed the existing entry.

I’ve looked at mine. Where I didn’t have additional identities I have replicated the original to make it work, i.e. new identity identical to the original.

I must be not understanding. I’ve never used mutliple identities for an account. When I create a second identity identical to the first and send a message to myself, it still shows in the message header as “me”.

Bill

Yes, screen size might be a good reason to behave differently.

But for this specific issue you cannot say screen size is a blocker to display mail adress instead of “Me” as K9 already displays the mail adress in case it is a multi identity account and adress is not the default one.

So, it would be best and very easy to add a new option for it and many users would be happy.

1 Like

I have done a few experiments and I have found a (not satisfactory) work around (with possible side effects).

  1. Clear all fields except “Email address” from initial identity
  2. Create second identity with the same email address, all other fields empty.

That sounds right but in my case the third step was to then enter an Identity description in the initial identity.

I found that the description is used instead of the email address, iow the description must have the email address to obtain the intended result. If you leave “Identity description” empty but enter something under “Your name” the identity will be shown as “Your Name ” and instead of “Me” the “Your Name” is shown in the message header. Leaving all fields except “Email address” empty causes “Me” to change to the email address.

The objective wish is to show the email address in the message header and that requires to leave "Identity description " and “Your name” empty, or alternatively to enter the email address as “Identity description”.

Makes sense doesn’t it ? My experience says that this type of “fix” will backfire later.

It has worked fine for me for however long it has been since that display change was introduced.

I use a descriptive name with some identities and the email address with others to meet different needs.

I finally got it to work by having only an email address in the original identity and by creating a new identity with a description, name, and the same email address. Now the email address shows instead of “me”.

Doesn’t seem to matter if I have a name or not.

Thanks all for the ideas.

Bill

1 Like

Why ? Have you thought about why you need to manipulate some configuration entry for outgoing mail to fix something to do with incoming mail?
This is the backfire caused by an earlier fix.